Jump to content

Recommended Posts

I am trying to put a new connection onto my ls pelso headphones, the original connector was only chrome plated, it rusted and somehow got bent.  The connector I want to use is a 90deg gold plated one that I have from another crappy pair of earbuds I got on ebay. 

I thought they'd have the same wires but after cutting them open they are different.  

The Lspelsos have a red wire and a white wire.  Thr Earbud connector has a red white and yellow wire.  

After connecting the reds to the whites and plugging it in to the equinox there was no sound

 

Can anyone offer any advice?

Much appreciated and hh

20210210_120224.jpg

20210210_120106.jpg

20210210_120000.jpg

Link to post
Share on other sites
  • stevejhgla changed the title to Headphone Cable Help

Well a couple of things!  That connector you have to the Equinox is a sub-standard hunk of junk. I just had mine fail and someone that knows connectors gave me the story on those. 

As for your connection. It won't hurt to find out what your correct parings are if you are wrong.  I would try red/red  white/white and yellow to bare. 

Work on getting a QUALITY connector to your detector!  

Dave

 

  • Like 1
Link to post
Share on other sites

I was just fighting with the same connector last night. After hours of searching, I ordered a different cable but don’t need it waterproofed.

I would suggest you search in all the detecting forums for a member that builds headphones and contact them. I read of a couple years last year but don’t remember who or where.

Good luck.

  • Like 1
Link to post
Share on other sites
10 hours ago, stevejhgla said:

After connecting the reds to the whites and plugging it in to the equinox there was no sound

Also one more thing I forgot. Once you have all the wires bare, hit them quickly with an open flame to make sure they do not have a coating on the little wire strands. There are examples on Youtube.  I just spliced my cable two days ago and I was Red/Red White/White and Black to Bare. 

  • Like 2
Link to post
Share on other sites
47 minutes ago, midalake said:

I just spliced my cable two days ago and I was Red/Red White/White and Black to Bare. 

By bare you mean the exposed copper wire right?

Last night I connected red/red/yellow and white/white.  It gave me sound but it was very faint....I'll take a crack at it again tonight.

Also I'll look into grabbing a new connector as well.  

Once I get the connections good I am transplanting everything into the 3m peltors like joe beechnut did to his excal headphones.  The LS pelsos are quite uncomfortable after a couple of hours hunting.

Thanks!

Link to post
Share on other sites
52 minutes ago, midalake said:

Also one more thing I forgot. Once you have all the wires bare, hit them quickly with an open flame to make sure they do not have a coating on the little wire strands. There are examples on Youtube.  I just spliced my cable two days ago and I was Red/Red White/White and Black to Bare. 

I think I saw that video too I'll make sure to do that 

Link to post
Share on other sites
On 2/11/2021 at 10:37 AM, stevejhgla said:

Can anyone help me source a good connector?

Thanks.

I would contact Tony Eisenhower, he makes headphones for the Nox. Maybe he will see this?  

  • Like 2
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Similar Content

    • By midalake
      Anyone running the new version of sunray phones???   thanks.
       
      https://www.robsdetectors.com/sun-ray-pro-gold-universal-headphones/
       
       
    • By Northeast
      Morning all,  
      I have been looking for something that will essentially work like a WM08 (the Equinox wireless receiver) but on the GPX 6000.  Something that can then simply have any type of earphone, earbud, on ear or over ear headphones attached to it.  
      I specifically wish to plug some Philips Sports earbuds into a Receiver.  They sit out of the ear to allow some ambient sound in so you are aware of surroundings.  And don't sit inside your ear like a proper ear bud that can get all sweaty and yuck.  I've used the Philips before and they are perfect for me.  

       
      The supplied Minelab GPX 6000 headphones work great - but I'm not keen on headphones as they are hot and they make it difficult to wear a broad brimmed hat.  I do recognise there are other hat options.   
       
      The non Bluetooth options:
      The Quest kit is great (  http://phasetechnical.com.au/product/quest-wirefree-mate-kit/  )  and  although I know they work really well, they definitely only pair with each other and I do not want to attach a Transmit unit to the GPX 6000 - possibility of EMI, an extra thing to get knocked off, an extra thing to charge and the functionality of a Bluetooth LL Transmitter is already in the GPX so why not use it!! 🤪   
      The Minelab Pro Sonic is too expensive and would need a Transmitter attached to the detector. 
      The Garrett Z-Link - would also need a Transmitter attached to the detector.  
       
      Bluetooth APTX Low Latency options:
      I have ordered the Avantree AS70 as it said they were due for release at the start of June.  But since ordering (4 days ago) that has been changed to the end of July  😤    https://avantree.com/au/as70-bluetooth-adapter-for-headphones   They are the latest version of the Clipper Pro previously mentioned on DP as having worked well.  The Clipper Pro seems completely unavailable now. 
      I like the look of the AS70 and Clipper Pro as they have a good clip that will attach to a shirt, collar, harness or whatever. 
      There are these  https://avantree.com/au/lock-bluetooth-transmitter-receiver-set    but they are a pair and I wonder if the Receive unit will work directly with the GPX or will it only pair with the Transmit unit (it does say auto pairing with each other in the write up).
      Chase Goldman had previously mentioned these as working well:
      TaoTronics 65ft Bluetooth Transmitter/Receive https://www.amazon.com/dp/B076BMT9BY
      TROND Bluetooth V5.0 https://www.amazon.com/dp/B01B4W40VC/       Newer version here     https://www.amazon.com/TROND-Bluetooth-Transmitter-Indicator-Simultaneously-dp-B01K8ANDCI/dp/B01K8ANDCI/ref=dp_ob_title_ce
      I notice the TaoTronics is currently unavailable on Amazon.
      At this stage I may get one of the newer Trond units as that will at least be a back up for my upcoming big trip and may end up being my main unit if the Avantree does not turn up in time.  
      There are a few others mentioned on this site  http://www.aptx.com/  but some look el-cheapo, some are no longer made (the site is not kept up to date in that regard), none of them have a clip to attach to clothing and I am unsure if any of them actually pair with a Vanguish/Equinox/GPX6.  
      Anything that pairs and works well in Low Latency with the Equinox/Vanquish should work well with the GPX 6000.  Would be even happier if my Equinox WM08 just hooked up (shame on you Minelab 😜)
      So my questions, finally!  
      What other brands have worked for people?
      Is the audio quality good?  Manufacturing quality good?  Somewhat weatherproof?
      Is the Low Latency good?   
      Have they paired easily with no issues? 
      What sort of time frame are the batteries lasting for most people?     
      Hoping you good people can share some 1st hand experiences - good or bad - and this can be a one stop resource for others searching for a similar device.  
       
      Cheers, N.E.  👍
    • By Stacy
      Has anyone tried one of these to waterproof their WM08 module?
       
       


    • By dbsmokey
      Last week,  I attempted to power on the ML 80 headphones I use with the Equinox 800.  I purchased these new in March 2019.  They would not power on.  I charged them:  the 3 red LEDs flash for about 10 minutes and then turn off, as if headphones were charged.  But, the headphones still will not power on.
      I attempted to contact my dealer and ML, but neither have yet responded.  Does anybody have any novel ideas to try, or troubleshooting, remedies?  I would greatly appreciate the help!
       
      Thanks,
    • By CanadianScouser
      As a new member of the forum I suspect this question has been dealt with many times in the past .I am having a problem linking my WM 08 to my Nox 600 .It just does not happen ,full charge on both and 2 ft apart .I have tried at least a dozen times .(headphones not turned on or involved .Can anyone help ?
    • By JimT
      I have asked some and received their ideas and suggestions 
      if you are running wireless which transmitter and headphones are you using. 
       
      What kind of run time are you getting out of the ones you chose ?  
       
      Sound Quality? 
       
      I can get the Z-Link or the Minelab sets up but thought someone might have a really good setup they have ran across
      Thanks 
      Jim
×
×
  • Create New...