Jump to content

Recommended Posts

I am trying to put a new connection onto my ls pelso headphones, the original connector was only chrome plated, it rusted and somehow got bent.  The connector I want to use is a 90deg gold plated one that I have from another crappy pair of earbuds I got on ebay. 

I thought they'd have the same wires but after cutting them open they are different.  

The Lspelsos have a red wire and a white wire.  Thr Earbud connector has a red white and yellow wire.  

After connecting the reds to the whites and plugging it in to the equinox there was no sound

 

Can anyone offer any advice?

Much appreciated and hh

20210210_120224.jpg

20210210_120106.jpg

20210210_120000.jpg

Link to post
Share on other sites
  • stevejhgla changed the title to Headphone Cable Help

Well a couple of things!  That connector you have to the Equinox is a sub-standard hunk of junk. I just had mine fail and someone that knows connectors gave me the story on those. 

As for your connection. It won't hurt to find out what your correct parings are if you are wrong.  I would try red/red  white/white and yellow to bare. 

Work on getting a QUALITY connector to your detector!  

Dave

 

  • Like 1
Link to post
Share on other sites

I was just fighting with the same connector last night. After hours of searching, I ordered a different cable but don’t need it waterproofed.

I would suggest you search in all the detecting forums for a member that builds headphones and contact them. I read of a couple years last year but don’t remember who or where.

Good luck.

  • Like 1
Link to post
Share on other sites
10 hours ago, stevejhgla said:

After connecting the reds to the whites and plugging it in to the equinox there was no sound

Also one more thing I forgot. Once you have all the wires bare, hit them quickly with an open flame to make sure they do not have a coating on the little wire strands. There are examples on Youtube.  I just spliced my cable two days ago and I was Red/Red White/White and Black to Bare. 

  • Like 2
Link to post
Share on other sites
47 minutes ago, midalake said:

I just spliced my cable two days ago and I was Red/Red White/White and Black to Bare. 

By bare you mean the exposed copper wire right?

Last night I connected red/red/yellow and white/white.  It gave me sound but it was very faint....I'll take a crack at it again tonight.

Also I'll look into grabbing a new connector as well.  

Once I get the connections good I am transplanting everything into the 3m peltors like joe beechnut did to his excal headphones.  The LS pelsos are quite uncomfortable after a couple of hours hunting.

Thanks!

Link to post
Share on other sites
52 minutes ago, midalake said:

Also one more thing I forgot. Once you have all the wires bare, hit them quickly with an open flame to make sure they do not have a coating on the little wire strands. There are examples on Youtube.  I just spliced my cable two days ago and I was Red/Red White/White and Black to Bare. 

I think I saw that video too I'll make sure to do that 

Link to post
Share on other sites
On 2/11/2021 at 10:37 AM, stevejhgla said:

Can anyone help me source a good connector?

Thanks.

I would contact Tony Eisenhower, he makes headphones for the Nox. Maybe he will see this?  

  • Like 2
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Similar Content

    • By JimT
      I have asked some and received their ideas and suggestions 
      if you are running wireless which transmitter and headphones are you using. 
       
      What kind of run time are you getting out of the ones you chose ?  
       
      Sound Quality? 
       
      I can get the Z-Link or the Minelab sets up but thought someone might have a really good setup they have ran across
      Thanks 
      Jim
    • By Purplehays69
      Got em today and am blown away so far with music...... Sounds like Dave Matthews voice is in the middle of my head..... WOW.....
    • By pinpointa
      E-mailed Centerville Electronics about Whites replaceable covers for ear muffs. No reply. Does any one know where i can get covers from .I am in Australia. Regards.
    • By mn90403
      Has anyone tried them with a metal detector?
      I came across an article which displayed some Bose audio sunglasses.  The concept was not something I had really considered but when you read about them they are built for athletes that need to be aware of their surroundings to avoid accidents.  We detect in areas where we need to avoid accidents and critters also so hearing outside of headphones is beneficial.  This would also have the potential of eliminating hot and or uncomfortable headphones for me in the desert.  I don't think they could work well at the beach with crashing waves.
      Maybe we can begin a review of these Bose and other audio sunglasses here.  Of course there would need to be some with LL and other technical specifications to work with our equipment but it could also be a new product idea for one of these companies. 
       
      https://www.bose.com/en_us/products/frames/bose-frames-tempo.html#D61A74D4CFE947DB6685D4D8CE1982FC 
    • By Nokta Detectors
      Dear Valued Members,

      We are adding 2 new headphones to our line-up.

      1)NOKTA MAKRO KOSS HEADPHONES W/WATERPROOF CONNECTOR
      Compatible with all waterproof Nokta Makro Detectors – Kruzer/Anfibio/Simplex
      Allows the user to submerge the whole detector in water for shallow underwater hunting.
      (The headphones are not waterproof).

      2)NOKTA MAKRO KOSS HEADPHONES W/6.3mm JACK – for land use

      BOTH HEADPHONES HAVE IN-LINE VOLUME CONTROL, ADJUSTABLE HEADBAND and SPIRAL CABLE.






    • By dbsmokey
      Last week,  I attempted to power on the ML 80 headphones I use with the Equinox 800.  I purchased these new in March 2019.  They would not power on.  I charged them:  the 3 red LEDs flash for about 10 minutes and then turn off, as if headphones were charged.  But, the headphones still will not power on.
      I attempted to contact my dealer and ML, but neither have yet responded.  Does anybody have any novel ideas to try, or troubleshooting, remedies?  I would greatly appreciate the help!
       
      Thanks,
×
×
  • Create New...