Jump to content

Recommended Posts

Last week,  I attempted to power on the ML 80 headphones I use with the Equinox 800.  I purchased these new in March 2019.  They would not power on.  I charged them:  the 3 red LEDs flash for about 10 minutes and then turn off, as if headphones were charged.  But, the headphones still will not power on.

I attempted to contact my dealer and ML, but neither have yet responded.  Does anybody have any novel ideas to try, or troubleshooting, remedies?  I would greatly appreciate the help!

 

Thanks,

Link to post
Share on other sites

Could be your charger. I have a headset that I was using a USB charger that had a quick charge outlet. When plugged into that outlet my headset would say that it was 100 percent charged but would only work 10 minutes and would say zero percent charged. I plugged them into a regular USB charger and they work for many hours. 

Link to post
Share on other sites

Mine are 2 years old and maybe the newer ones are different but the red LEDs never blink. They stay on solid until charged then turn off.

 

I would keep trying your dealer and ML to see if yours came with a fault.

Link to post
Share on other sites
3 hours ago, FloridaSon said:

Mine are 2 years old and maybe the newer ones are different but the red LEDs never blink. They stay on solid until charged then turn off.

I have two WM08 receivers, the original that came with my 800 three years ago and another that I bought ('used') on Ebay and for which I don't know its history.  (I probably bought it about a year ago, maybe a bit less.)  My original does not blink when charging but the one I bought on Ebay does.

Link to post
Share on other sites
17 hours ago, dbsmokey said:

Last week,  I attempted to power on the ML 80 headphones I use with the Equinox 800.  I purchased these new in March 2019.  They would not power on.  I charged them:  the 3 red LEDs flash for about 10 minutes and then turn off, as if headphones were charged.  But, the headphones still will not power on.

I attempted to contact my dealer and ML, but neither have yet responded.  Does anybody have any novel ideas to try, or troubleshooting, remedies?  I would greatly appreciate the help!

 

Thanks,

Hi ,I had an issue with my ML80 headphones a year ago. The ON/OFF button was broken . I sent it back to my seller and they sent me a brand new one. May be it is related with your pb I dont know ... Anyway those ML80 buttons are fragile compared to the Garrett MS3 headphones for example

  • Like 1
Link to post
Share on other sites

Thank you all.  I  misspoke:  the red LEDs are solid (not blinking) for a few minutes and then go out; which, according to the headphone user guide, indicates a full charge.  I will attempt to find another cord to use to charge them.  I have attempted both an AC adapter on the USB charging cord and directly connecting it to both a computer and a power-strip USB port, all with the same result.

I will continue my attempts to contact ML and the Dealer.  Thanks again, all

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Similar Content

    • By CanadianScouser
      As a new member of the forum I suspect this question has been dealt with many times in the past .I am having a problem linking my WM 08 to my Nox 600 .It just does not happen ,full charge on both and 2 ft apart .I have tried at least a dozen times .(headphones not turned on or involved .Can anyone help ?
    • By JimT
      I have asked some and received their ideas and suggestions 
      if you are running wireless which transmitter and headphones are you using. 
       
      What kind of run time are you getting out of the ones you chose ?  
       
      Sound Quality? 
       
      I can get the Z-Link or the Minelab sets up but thought someone might have a really good setup they have ran across
      Thanks 
      Jim
    • By Purplehays69
      Got em today and am blown away so far with music...... Sounds like Dave Matthews voice is in the middle of my head..... WOW.....
    • By pinpointa
      E-mailed Centerville Electronics about Whites replaceable covers for ear muffs. No reply. Does any one know where i can get covers from .I am in Australia. Regards.
    • By mn90403
      Has anyone tried them with a metal detector?
      I came across an article which displayed some Bose audio sunglasses.  The concept was not something I had really considered but when you read about them they are built for athletes that need to be aware of their surroundings to avoid accidents.  We detect in areas where we need to avoid accidents and critters also so hearing outside of headphones is beneficial.  This would also have the potential of eliminating hot and or uncomfortable headphones for me in the desert.  I don't think they could work well at the beach with crashing waves.
      Maybe we can begin a review of these Bose and other audio sunglasses here.  Of course there would need to be some with LL and other technical specifications to work with our equipment but it could also be a new product idea for one of these companies. 
       
      https://www.bose.com/en_us/products/frames/bose-frames-tempo.html#D61A74D4CFE947DB6685D4D8CE1982FC 
    • By Nokta Detectors
      Dear Valued Members,

      We are adding 2 new headphones to our line-up.

      1)NOKTA MAKRO KOSS HEADPHONES W/WATERPROOF CONNECTOR
      Compatible with all waterproof Nokta Makro Detectors – Kruzer/Anfibio/Simplex
      Allows the user to submerge the whole detector in water for shallow underwater hunting.
      (The headphones are not waterproof).

      2)NOKTA MAKRO KOSS HEADPHONES W/6.3mm JACK – for land use

      BOTH HEADPHONES HAVE IN-LINE VOLUME CONTROL, ADJUSTABLE HEADBAND and SPIRAL CABLE.






×
×
  • Create New...