Jump to content

Not A Good Sign That You Are Going To Have A Good Day At The Beach...


Recommended Posts

Pins are no different on the old Minelab sovereign and Excalibur shafts (set low). I've broke a few of them over a 12 year period but never a Whites. I broke them because of me leaning on them when digging which will cause stress cracks then a eventual fail. Where is my Buddy Dew, that's his number one thing to break. 

 

SNAG-0007.jpg

  • Like 5
Link to comment
Share on other sites


I don’t think any shaft will hold up to being a crutch. Coil ears as well. Don’t see the 12 1/2” coil ears ever breaking on the Impulse but the new clevis design may now apply pressure differently on the shaft. I’m sure that Fisher will come up with a solution though. Give me that Minelab ISO rod “ clevis “ any day !

  • Like 2
Link to comment
Share on other sites

I’m not sure there’s a part I’ve not broken on a water machine.  Joe knows me best he’s fixed a lot of um for me.  I’ve split coils, broken ears, shafts, cuffs.... but hey from it all I’ve learned a lot.  I can also say I never broke anything to my knowledge when dirt hunting.   That’s why I’ve always said .... plan for ... stuff breaks in the water especially...  thank goodness we find some gold. 

  • Like 5
Link to comment
Share on other sites

Here are some more pictures of the break.  From what I see, there was salt water intrusion around the pins that were supposed to be sealed in epoxy.  I hope that this was an isolated case and not the norm.  

The broken shaft was received by FT today (April 29) at 10:23 AM.  I have yet to receive my replacement, nor have I heard anything more from FT about it.  I would have thought that the replacement would have been sent out on Monday also.  I was  in contact with Russ, Felix and Alexandre all on Monday and nothing since.  On a good note, I got gold ring #7 with my Equinox yesterday.  

IMG_9965.jpg

IMG_9964.jpg

IMG_9963.jpg

IMG_9962.jpg

  • Like 2
Link to comment
Share on other sites

Looks like the holes for the pins are pretty deep and drilled. Lets see what they come up with, but I would think pinning (and only drilling) on one side would be enough and leave less of a chance of failure at the pin location than there is with holes coming from both sides. Or just epoxy the fitting in the shaft.

I have had two Excal coil mounts come loose from the shaft (fell out). I epoxied them back in and neither one has had a repeat.

  • Like 1
Link to comment
Share on other sites

Is that coil connector a SOLID piece?  I wouldnt want it drilled from just one side.  Ive found when using those spring clips a single will allow movement with torque no matter the shaft lock over time it will wear.  To me it seems a little epoxy added would do the job along with just one of those pins.  Sometimes chit happens.   Havent seen Orka Gold post about his lower shaft that didnt come with his small coil yet either .... they seem slow on repairs but this may well be the times we are living in currently.  Its taking longer on a lot of things now days.

Link to comment
Share on other sites

2 hours ago, vive equinox said:

alexandre or someone else, do you know if there will be customer service in europe when it is delivered on that continent?

Yes there is an importer in Europe who takes care of this.

It is he who will manage the exchanges and guarantees.  It is located in eastern Europe.

Link to comment
Share on other sites

6 hours ago, dewcon4414 said:

Havent seen Orka Gold post about his lower shaft that didnt come with his small coil yet either ....

Hello Dewey. It shipped on 4-28. Anxious to see how it performs. BUT... check out my latest post today.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Similar Content

    • By The_Stalker
      Received my catalog from Kellyco today and they proudly announced that they are looking forward to offering the Fisher Impulse AQ in 2022.  The write up that Kellyco gave made it sound like there was substantial discrimination with minimal loss of detection depth with the AQ.  We shall see.
       
       
    • By Mick93
      We do like Steve,  wife sold her nox 800 just before 3 years and ordered her new one. Showed up today and she was all excited ,put it together, charged up ready to try it out. Well the on/off switch wouldn't work!  She was a little disappointed but Minelab said send it in, so off it went !
    • By midalake
      Man Damages Stonehenge While Treasure Hunting, Posts Finds Online
      https://www.msn.com/en-us/news/world/man-damages-stonehenge-while-treasure-hunting-posts-finds-online-police/ar-AAPwmti?ocid=msedgntp
    • By Goldseeker5000
      So some of you know that my 6000 arrived defective right out of the box and that I sent it back to be replaced the morning after I got it. Well the new replacement arrived yesterday and the detector works as I assume it should. Well, at least it will sound off on a nugget, so I assume it is working properly. I have the 14" DD on to test that out. When I picked up the 11" to pull it out of it's plastic bag, I noticed something odd on the top of the coil. There was a crescent shaped crack in the coil. What in the world is going on with Minelab and their quality control.?!! People spend thousands upon thousands of dollars on their detectors, you would think they would be more strict and precise with their quality control procedures. I sent the 11" coil back to be replaced, this morning at 9 am. It is possible it could have happened in shipping, however the inner box and shipping box were in great condition. No smashed areas anywhere on the boxes. Anyone else  want to chime in about their particular Minelab detector defect. If Minelab is reading this, you have alot of people out there spending alot of money on your detectors because they are the best-Hands down, but it seems like since the sdc2300 came out the quality control is going down hill. I understand some defects can get by or crop up over a little bit of use, but this is not good.

    • By oldcoinhunter
      Just got a XP ORX with the 9x5 HF coil and the coil battery won't charge. The control battery charged up fine but when i try to charge the coil battery the light on the coil blinks every three seconds like it is charged when it is only 30 % charged. The light never stayed on continually like it says in the manual when i first hooked it up and yes i have it hooked up the right way. Thanks, Jim
    • By Thomas Hyche
      I have a White's Spectrum XLT. Several years ago a rogue wave washed over it at the beach and then it quit. The LED screen is still good but I get no action out of box, so, is there a place that I can purchase a mother board for it?
      Thanks
      Thomas
×
×
  • Create New...