Jump to content

Please Help ( Fix Gold Monster )


Recommended Posts

Looks like your control pod has failed to me, it's behaving like the coil is bad and if you've tried another coil that only leaves the control pod.  Hopefully it's still under warranty.

  • Like 3
Link to comment
Share on other sites

On 24‏/3‏/2022 at 01:29, wltdwiz said:

حاول إخراج البطارية ثم اضغط على زر الطاقة ثم أدخل البطارية مرة أخرى وحاول تشغيلها



On 23‏/3‏/2022 at 07:32, phrunt said:

يبدو أن جراب التحكم الخاص بك قد فشل بالنسبة لي ، إنه يتصرف كما لو كان الملف سيئًا وإذا كنت قد جربت ملفًا آخر لا يترك سوى جراب التحكم. نأمل أنه لا يزال تحت الضمان.

I tried it and the problem is still there

Thank you

Link to comment
Share on other sites

  • 2 weeks later...

I’ve never had a gold monster but here is what I would do:

get a can of De-Oxit and spray both coil connections. Blow them with compressed air.  If the detector has a pinpoint mode and will output audio you may be able to move the cable at the connection and coil to check for opens.

if no luck, let me know what Minelab says. Is this another detector not repairable by design?  

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...