Jump to content

Self Servicing The Fisher Impulse?


Recommended Posts

Who is your phone contact at First Texas if you want to discuss anything regarding the AQ you own?

Edit: never mind, I finally got Felix by asking for "service".

He explained there is no warranty carryover - which I expected.

Let me know if any of you open this thing up (take photos!).  I fully expect to maintain this all on my own if I can.

Edited by bklein
prefer to delete but don't see the option.
Link to comment
Share on other sites


4 hours ago, bklein said:

Who is your phone contact at First Texas if you want to discuss anything regarding the AQ you own?

Edit: never mind, I finally got Felix by asking for "service".

He explained there is no warranty carryover - which I expected.

Let me know if any of you open this thing up (take photos!).  I fully expect to maintain this all on my own if I can.

Not so sure you can get it apart. Most everything is glued or epoxied in place. Joe and I have talked about it but neither one attempted yet. Joe and I both tried the battery and failed short of destroying it. Eric found that the metal locknut on the female Souriau connector was a source of capacitance that created issues in the salt water. After much ordeal he was able to drill it off as it is glued in place to replace it with a plastic locknut he cut and threaded. Let us know if you bust it open. I believe it has few if any serviceable parts. CJC says the pots are junk and should be the first to fail. VaShay I believe. I have no idea if FT will service the limited edition after warranty expires.

  • Like 2
Link to comment
Share on other sites

Felix wasn’t that conversational. He said to send an email if I have specific wants. I tried my AQ first time, at Laguna. After I first turned it on it was going kinda wacko. Stuck in a high gain noisy state like the Equinox at 25.  Adjusting controls didn’t really affect it it all of a sudden it cleaned up and played nice.  I didn’t really see much validity in the tone mode - everything iron was high tone. Sometimes I got a second tone but I was fine hunting in all metal.  My battery lasted maybe an hour.  The lithium ion battery connections were 180 degrees out from my receptacle! Is this an OBN battery?  I had to hold it in the arm strap and just grab the handle. Will I be able to rotate the receptacle or is it glued in?  The coax seal was a mistake. Gunky mess. Electrical  tape should do. I found several coins and some deep things but no gold.  Does like nickels.

Link to comment
Share on other sites

2 hours ago, bklein said:

Felix wasn’t that conversational. He said to send an email if I have specific wants. I tried my AQ first time, at Laguna. After I first turned it on it was going kinda wacko. Stuck in a high gain noisy state like the Equinox at 25.  Adjusting controls didn’t really affect it it all of a sudden it cleaned up and played nice.  I didn’t really see much validity in the tone mode - everything iron was high tone. Sometimes I got a second tone but I was fine hunting in all metal.  My battery lasted maybe an hour.  The lithium ion battery connections were 180 degrees out from my receptacle! Is this an OBN battery?  I had to hold it in the arm strap and just grab the handle. Will I be able to rotate the receptacle or is it glued in?  The coax seal was a mistake. Gunky mess. Electrical  tape should do. I found several coins and some deep things but no gold.  Does like nickels.

I guess the battery was never used. Everyone that bought one was sent instructions that you have to pull the M-8 fitting off of the AQ and turn it around. 

Not sure which battery you got but I made 2 diff.. a 5.5 hour and a 11 hour one. Full charged should be around 16 plus volts..16.4 to 16.8

O and I made one 8 hour battery, that one is pictured below on the far right..TVR got it

On the wacko, that is possibly a overload. If you have any large pieces of metal under or near the coil it will go into the motor boat sound also other machines that are on when you turn the AQ on will cause the same.. So you have to turn it off and set it somewhere it is clean then turn it on...

21a.jpg

20.jpg

119474678_1074503896302312_7506924594866483958_n.jpg

119428937_416398529342778_2788654728811392419_n.jpg

  • Like 2
Link to comment
Share on other sites

Only thing I would add is that after turning the connector around, I worked a bamboo BBQ skewer through the hole to make sure the wires were out of the way before pushing the metal screw through. I have no desire to nick the insulation on the wires!

  • Like 1
Link to comment
Share on other sites

Where do we get these orange o-rings? Mine is missing the outer one shown in the photo.

Another thing is the coil attach screws. I went to take the detector out of my car and one fell off. I found it but it got me thinking I need to get spares or devise a way that it for sure doesn’t come apart.

(thanks for the tips on the receptacle- mine’s good now)

Link to comment
Share on other sites

8 hours ago, bklein said:

Where do we get these orange o-rings? Mine is missing the outer one shown in the photo.

Another thing is the coil attach screws. I went to take the detector out of my car and one fell off. I found it but it got me thinking I need to get spares or devise a way that it for sure doesn’t come apart.

(thanks for the tips on the receptacle- mine’s good now)

Pretty sure that is a Joe mod, for the power connector if you will. I imagine digikey or maybe mouser would have them. Here is a picture of my machine at Eric’s house with a similar black O ring and plastic locknut on the Souriau coil connector. I’m sure Joe will give a part number when he sees this. I would caution for both mods, to be sure that the mating of the inner O ring which actually is the water tight seal is not impaired by the outer mod O rings.

354B495D-4DE5-4E16-9B78-C73E5D460C08.jpeg

A9CE2AEE-DBB2-46DD-8FE6-54D138427802.jpeg

  • Like 1
Link to comment
Share on other sites

11 hours ago, bklein said:

Where do we get these orange o-rings? Mine is missing the outer one shown in the photo.

Another thing is the coil attach screws. I went to take the detector out of my car and one fell off. I found it but it got me thinking I need to get spares or devise a way that it for sure doesn’t come apart.

(thanks for the tips on the receptacle- mine’s good now)

Mine was also missing. I don't think I ever saw an orange oring.

Link to comment
Share on other sites

Here is my stock battery.  See how the top is popping up? Is this normal, or means the cells are bad? It only ran the detector an hour or so first run.734C554A-4562-4152-AA0C-7DEB500A3CF4.thumb.jpeg.d4dc47dba4c05e631274861d4ed80faf.jpeg

Link to comment
Share on other sites

49 minutes ago, bklein said:

Here is my stock battery.  See how the top is popping up? Is this normal, or means the cells are bad? It only ran the detector an hour or so first run.734C554A-4562-4152-AA0C-7DEB500A3CF4.thumb.jpeg.d4dc47dba4c05e631274861d4ed80faf.jpeg

It does not look correct. Normally I would say overcharging battery issue. Mine at first only gave me 2 1/2 hours at best. I gave one to Eric and the other one has gone flat and won’t take a charge from non use since I bought one of Joes batteries. If I can get it to charge you can have it. Will be in touch tomorrow. Since Joe sold a lot of batteries maybe someone else can help you. They are not worth what Fisher sold them for.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...