Jump to content

Mi 6 Is Not Very Powerful


Recommended Posts

My MI6 is one that I've had so that might be part of the problem. But while using it with the D2 it is really weak. While it's on and I go to the menu on the controller I can max it out at 50 but it still does not work well. I have to almost touch a coin to set it off. I charge it fully. I've tried both of the audio settings. The Garrett carrot is at least 5 times better. Are there any other settings that are available to make it work better? Or .... toss or replace? thanks

Link to comment
Share on other sites


5 hours ago, martygene said:

My MI6 is one that I've had so that might be part of the problem. But while using it with the D2 it is really weak. While it's on and I go to the menu on the controller I can max it out at 50 but it still does not work well. I have to almost touch a coin to set it off. I charge it fully. I've tried both of the audio settings. The Garrett carrot is at least 5 times better. Are there any other settings that are available to make it work better? Or .... toss or replace? thanks

My MI 6 kills the Carrot at sensitivity 50, pitch audio and max pitch frequency.  Be sure to save the custom settings (which is saved to Pinpointer Pgm 4) or it  will revert to default settins. If yours continues to underperform, likely yours is broken/defective.  

  • Like 2
Link to comment
Share on other sites

I didn't buy an MI-6, instead an MI-4 as I don't intend to be a Deus owner, however the Mi-4 is very similar in performance to my Garrett AT, so if its not performing at that level, it must be faulty.

  • Like 1
Link to comment
Share on other sites

I agree yours does not seem to be working right. 

  • Like 1
Link to comment
Share on other sites

in a way, I'm glad that I'm not the only one. Maybe it will work better whenever I decide to upgrade to v7.xxx

Link to comment
Share on other sites

I just tested this and it appears to be related to one of the updates, not sure if .70 or .71 version, when not paired it works as expected and sensitivity is great. Volume and sensitivity weak when paired. I am sure this will be addressed in a future update.

Turn on, hold power button for 5 seconds, when you feel the vibration press the button twice and you will get back the performance (you may know this just posting it in case you dont).

  • Like 2
Link to comment
Share on other sites

2 minutes ago, eklarsen said:

I just tested this and it appears to be related to one of the updates, not sure if .70 or .71 version, when not paired it works as expected and sensitivity is great. Volume and sensitivity weak when paired. I am sure this will be addressed in a future update.

Turn on, hold power button for 5 seconds, when you feel the vibration press the button twice and you will get back the performance (you may know this just posting it in case you dont).

thanks... I'll probably use the carrot until I do the update and see how that goes...

Link to comment
Share on other sites

These kinds of bugs popping up from one update to the next is getting under my skin and the reason I haven’t updated my Deus 2 since I got it. Some issues are minor annoyances and some are major pains in the ass. Either way I want no part of it. Hopefully a nice clean update will be forthcoming as I do like some of the new features. Get it together XP. You’re a top tier manufacturer now.

  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...