Jump to content

Deus 2- Coil Won’t Pair With Control Unit


Recommended Posts

I thought the coil would already be paired- No idea what I’m doing wrong. Tried entering serial number process, still not pairing. Coil is fully charged, but because it’s not linking up it shows empty battery on the screen. Any help would be greatly appreciated. Thanks. 981EC515-F249-412C-949D-0454CD0EF6D9.thumb.jpeg.6c6fba5afa0d35f5494ae1c92dc780eb.jpeg

  • Like 1
Link to comment
Share on other sites


Yes the coils are typically already paired in the full Deus 2 kits.  But there could be reasons whey it came unpaired, both innocent and nefarious (e.g., well-intentioned or unscrupulous post-delivery component switching, such as from a returned purchase or dealer switchout due to a known failed component).  First thing to do is make sure the coil is showing a heartbeat LED pulse.  That shows that the coil is likely operational and that there is at least enough coil battery charge to pair the coil.  The next thing to check is to make sure you are entering the right serial number.  The serial number is, I believe, hexadecimal-based, so it usually has letters and numbers combined (a combination of six of the following digits and letters: 0 1 2 3 4 5 6 7 8 9 A B C D E F) and the D sometimes gets visually mistaken as a 0 (or vice versa) based on the styling of the letters.  Take a pic and post your coil serial number and let us know what you are entering, maybe you are off by a digit or letter.  If not, you might have a DOA coil, unfortunately, and will have to inform your dealer.  HTH

Link to comment
Share on other sites

I think I’ve got a defective coil- right after I’ve charged it for several hours the light will blink every 3 seconds or so and then quit within a few minutes. I’m going to return the unit. Thanks again. 

  • Like 1
Link to comment
Share on other sites

The photo of the display screen shows your coil as having little or no charge. That is what mine did when I forgot to notice its battery level.

Are you sure that the charging clip is really making good contact when charging. Does the coil LED stay on continuously when charging?

Link to comment
Share on other sites

Jeff- I’ve made sure the clip is securely connected, and attempted to charge the coil at least a half dozen times. Sometimes the charging light will come on, then goes off shortly. Also, I only get the standby blinking light for a short time and it quits. In addition to that I get a pop up on my screen asking for the coil serial number. I truly think the coil is defective. I appreciate your input. 

Link to comment
Share on other sites

10 hours ago, Jeff McClendon said:

The photo of the display screen shows your coil as having little or no charge. That is what mine did when I forgot to notice its battery level.

Actually, that's the no coil is connected icon.  

  • Like 1
Link to comment
Share on other sites

I

2 hours ago, Chase Goldman said:

Actually, that's the no coil is connected icon.  

Actually,  if the coil’s battery runs down enough it will unpair……or at least display the no coil connected symbols. 
 

It pairs up immediately when the battery charge level increases enough. 
 

It’s happened to me twice. I didn’t notice that my coil battery level was low. 

  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...