Jump to content

Problem With Mi-6


Recommended Posts

It's anyone else having a problem with the MI-6 not connecting to the D2 when switching it on? Sometimes it takes as many as 3 or more attempts to get it to connect. I've noticed this since day 1, and while it does eventually connect it's a bit annoying. I've re-paired it, tried a frequency check to see if it might be EMI, but have come to no conclusion. Some places it works flawlessly, others not so much. 

  • Like 1
Link to comment
Share on other sites


My MI-6 connects almost every time if It’s held close to the RC in the D2.  If it doesn’t connect, a re-tune press of the button usually makes it connect.  Annoying, not at all like my carrot with Z-Lynk.

My son has a D2 and an MI-6 and has the same connection problem you are experiencing.  Maybe a defective MI-6?
 

Maybe it’s time to contact your seller, or XP for warranty repair.  HH.

  • Like 2
Link to comment
Share on other sites

1 minute ago, DIG5050 said:

My MI-6 connects almost every time if It’s held close to the RC in the D2

At least you write "almost"... 😀 Yeah I try to keep it close but shouldn't have to. It does seem not to connect if the detector has something else going on like a stray signal, I've tried frequency scan but to no avail. I'll try the re-tune, Thanks! May have done that inadvertently once or twice. 👍

  • Like 1
Link to comment
Share on other sites

I am experiencing the same annoying behavior too. It is great to be a more silent detector user in public areas but the inconsistent pairing and Mi-6 inconsistent sensitivity levels after pairing should not be happening with a detector at this price level. 

  • Like 4
Link to comment
Share on other sites

Samie same... frustrating and annoying... 

  • Like 1
Link to comment
Share on other sites

I think dig5050 may have a shortcut, going to try retune. 🙂

Link to comment
Share on other sites

Same here connects 3/4 of time 1/4 fail requiring restarting mi6. I keep a mi4 with me when I have many targets cause I can leave it on- it turns off on its own but by then I’ve dug 2-3 targets and just keep turning it on. I leave it on and hold it under my left arm ( pit) where it won’t detect metal and is always ready for the next hole. 

  • Like 1
Link to comment
Share on other sites

I haven't paired my Mi6 up as yet, I am going for a hunt in the next few days I must give it a try and see if it behaves the same...currently running 0.71 firmware.

  • Like 1
Link to comment
Share on other sites

Yeah,,, I used the MI6 first time out, had it paired up & set. Somehow the sensitivity settings got messed up, got tired of screwing around w it and went back to the car for the ever reliable Carrot. Still haven’t used the MI6….🙄

Aaron

  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...