Jump to content

Is There An Instruction Sheet How To Update The Legend?

Recommended Posts

2 hours ago, bobinyelm said:

Updating to V1.09 (or other upgrades) for The Legend

This series of steps worked for me when other did not. Try it if nothing else works!

1) Go to Nokia Website
2) Click on "Metal Detectors", and select "Coin and Relic," and then "The Legend"
3) Scroll Down to, and Click "Software Update" in the Left Column
4) Scroll to " Download: The Legend Update Tool (Windows) Includes System Software V1.09 - V1.07 - V1.05". and click once to Download to your Computer聽
5) Monitor the Download on the Lower Left of your screen...
6) When the Download is complete, Click : "Show in Folder"
7) Right Click on the highlighted file you downloaded, and click "Unzip All"
馃槑 You should have a File Called "the_legend_update_tool_v1_6_win"* containing 聽2 Unzipped Files. One will be"CP210_Windows_ Drivers," and "The_Legend_Update_Tool"
*Other files may have different names, of course.
9) Double Click on the "CP210_Windows_ Drivers" File and when it expands, double click on the "X64" and follow the instructions to load the drivers on your computer*
*Once you've downloaded and installed the drivers, you won't have to install those again.
10) Double Click on the file: 聽"The_Legend_Update_Tool" 聽(or the upgrade you wish) 聽 and click "Run" and follow the instructions precisely, plugging the Legend into your USB Port when asked .
Note for Update, after completing the above, do a Factory Reset (Step 8 under V1.09 Features shown below the new features of your download).

When you do Step 10 (above) a Step-by-Step tutorial video will open that will lead you through the complete process precisely,

Good luck, and if you have corrections, let me know and I will revise my post!


The first updater tool they had was a pain in the butt when I received my legend it was in the first shipment to hit the U.S all those Legends had 1.04 then they came out with 1.05 it took me 17 hours to get the install of 1.05 to go and when it finally did go there was no rhyme or reason as to why the 1.05 finally installed,the next update was 1.06 it installed with in seconds then 1.07 came out to all of us and again it took hours to get it to finally install the 1.08 software went fairly smooth and then within a few days they came out with 1.09 and a new installer tool shortly after, and then just recently updated the installer tool from V1-5 and to what is now the V1-6, 1.05, 1.07 and 1.09 is in that one install tool, not that I can tell you how to get to the 1.07 or 1.05 versions firmware in that updater tool because every time I have re installed the 1.09 update the 1.09 is showing in the tool to do the update

The one thing I have discovered is if you try to update the firmware you want to do it using a windows 10 PC be it a lap top or a desktop because it will not work using a windows 11 PC anything and I do not know why, at least it has not worked for me using a windows 11, I do not own a Mac so I have never tried on one of them

the other thing you want to shut down your firewalls and anti virus when you are doing the installs because if you do not it does not seem to want to let them install I set both to come back on when I restart my PC and when I am finished doing the install of a new version I restart my PC so as to not forget to turn my firewalls and anti virus back on

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...