Jump to content
Website Rollback - Latest Updates ×

CTX 3030 Owners


strick

Recommended Posts

Check your cables. This is the Cable that goes to the control panel not the coil cable. Recently I noticed that the screen back light would not turn on...now the screen itself is dimming out with shadows...This is a 2017 model. The interesting thing was that I had a an screen giving me problems on my first CTX but I never checked the cable I just sent it in to be fixed. wondering if this is a common problem.

strick 

thumbnail (7).jpeg

  • Like 1
  • Thanks 2
  • Oh my! 6
Link to comment
Share on other sites


Could be some animal chewed on it? Unfortunate.

  • Like 1
  • Haha 1
  • Oh my! 1
Link to comment
Share on other sites

23 minutes ago, Rick N. MI said:

Could be some animal chewed on it? Unfortunate.

Worms did that, got tired of him taking all their coins ?

 

  • Like 1
  • Haha 4
Link to comment
Share on other sites

That's a pretty serious tear. I'm wondering if swinging the machine moves that cable slightly and eventually causes that or if the material just breaks down after time. But it looks like it gets hung up somewhere until it tears open.

Link to comment
Share on other sites

1 hour ago, schoolofhardNox said:

That's a pretty serious tear. I'm wondering if swinging the machine moves that cable slightly and eventually causes that or if the material just breaks down after time. But it looks like it gets hung up somewhere until it tears open.

Thinking opening and closing the housing to remove the coil cable when you change coils. It pulls the damaged cable taught...the strange thing is that the cable has a unusual bend in it where the break is. That cable was never removed since I put the detector together as the instructions say to do so back in 2017. Maybe others wont have this issue but posting just in case. 

strick 

  • Like 2
Link to comment
Share on other sites

2 hours ago, Rick N. MI said:

Could be some animal chewed on it? Unfortunate.

You should see what rats did to my boat wiring a few years ago...nice clean job looked like you cut the wires with a sharp pair of dykes.

strick

  • Like 1
Link to comment
Share on other sites

Every winter mice would make nests inside my carburetor on my dirt bike. Not an easy thing. So every spring I had to take it apart and clean it. They never chewed on anything though fortunately. Never had anything chew on my detectors either.

Link to comment
Share on other sites

Maybe it got pinched somehow closing the detector up after a coil change.  At least that's an easy enough one to self-fix. 

If it's a problem with the CTX it'd also be a problem with the GPZ you would think, especially now with aftermarket coils available and people changing coils more often as previously people invested in the 19" coil, tried it once and then threw it out, fitted the 14x13' and never needed to change coils again until the aftermarket coils arrived. ?

Hopefully it's a one off, I guess people concerned about it could shrink some dual wall heatshrink over it to add a bit more meat to the cable.

This is what the full LCD cable looks like, same cable for the GPZ and CTX.

1373425051_lcdcable.jpg.ec9ffea90db08b148c7a16498c2d1747.jpg

  • Like 2
Link to comment
Share on other sites

I tried to source the cable but could not find it...I'll keep looking. maybe the repair center can send me one.. I watched the video of the guy doing the ctx tear apart. That cable is straight and does not have a kink in it like mine does so you may be right. 

strick

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...