Jump to content
sdbirder

66 Audio-bts Pro Bluetooth Headphones Aptx Ll

Recommended Posts

The person who sent me the firmware was Caroline B. I had another exchange with an Emily O., who appeared clueless and just copied and pasted a long blurb about no plans to support LDAC or aptX-HD, and audio listening tests and groups and the difference between our current aptX and aptX HD was non-existent.

I'd give it one more try and put ATTN Caroline B. Unfortunately I don't have her direct email, just support@66audio.com.

If that doesn't work Amazon has great return policies.

Good luck!

Share this post


Link to post
Share on other sites

1 hour ago, Chase Goldman said:

How did you know that was Emily's response.  Lol.

They sent a follow-up email asking how things were going and Emily's response didn't make any sense? Probably a copy and paste response.


----------
From: sdbirder
Date: Fri, Jun 8, 2018 at 4:14 PM
To: 66 Audio Support <support@66audio.com>

Overall its working good with the aptX LL firmware. Occasionally it'll freeze up when I try listening to music on my phone or pc. Hooking it up to the charger snaps it out of the freeze. Please let me know if you release any further refined aptX LL firmware.

Thanks, sdbirder

 


----------
From: 66 Audio Support <support@66audio.com>
Date: Mon, Jun 11, 2018 at 11:48 AM
To: sdbirder


Hi sdbirder, 

Thanks for your message. We currently have no plans to support LDAC or aptX-HD. We’ve thoroughly ran audio listening tests and groups and the difference between our current aptX and aptX HD was non-existent.

BTS Pro and PRO Voice uses the latest generation of Qualcomm aptX as well as our own 66 SoundEngine DSP which further enhances the audio profiles in numerous ways. Additionally, the headphones use very unique and high-end stereo drivers with optimal frequency response curves and low THD for the best listening experience.

Let us know if you have any more questions.

Best, 
Emily O. 

66 Audio Support
support@66audio.com
M-F 10am - 8pm PST

Share this post


Link to post
Share on other sites

sdbirder,

Welp, I switched over to the BTS Pros, installed the latest firmware and they do not connect with the Equinox as  aptx-ll (no plus sign with the bluetooth symbol) so I don't know how you got yours working in aptx-ll mode.  Are you seeing the plus sign on your Equinox display when the BTS pros are connected?

Share this post


Link to post
Share on other sites

Ok - got that straightened out an downloaded from the link you posted above instead of the link 66 Audio support sent me and the headphones updated to APTX-LL and confirmed with the "+" symbol on the Equinox so we are good to go.  Great backphones for summer use and being water resistant don't mind wearing them at the beach and in foul weather.  Not made for a full dunking by they will get the job done in waist deep water.  Great sound, great ergonomics and if you shop around, they can be snagged for less than $100.  I recommend these for warm weather detecting.

  • Like 1

Share this post


Link to post
Share on other sites

I also used to have a Deus and really liked the backphones. They're light, and great if you want to wear a broad brim hat. After reading this thread I bought a pair of BTS Pros, and using the firmware link provided by sdbirder, updated them to APTX LL. Thanks for the info and the link...awesome!

  • Like 1

Share this post


Link to post
Share on other sites

I too am coming from the Deus, and I have tried the Miccus Sr-71 Stealth phones, and they are great, but the summer heat is unbearable with those phones.  I bit on the BTS Pros, and out of the box they pair but NOT in Low Latency mode on the Equinox 600 (as expected).

I tried to run the Windows update from their site (1.08), and it gives:

Firmware Update Error

Program was unable to connect to the headset

Please check again that cable is connected and headset is powered off.

Error -2

 

I did all the pressing of the 3 buttons, standing on my head, facing east, etc, nothing changes.

I am going to let them charge overnight and try again.

The updater posted by sdbirder also failed giving an error on that command prompt window it opened:

 

HidDfuCmd.exe upgrade 0a12fffe00 aptx-ll-enable.dfu

HidDfucmd.exe, version 2.6.2.632 Release

Copyright Cambridge Silicon Radio Limited 2012 - 2015

Error running upgrade command: Invalid Sequence (HidDfuConnect must be called first)

Press any key to continue...

 

I assume a regular Windows 10 PC should work fine for either of these updates?

Do I have to run in XP SP3 mode, administrator, some sort of special mode?

I have tried 2 desktops and a laptop (all windows 10 fully updated) , and the result is the same.

I am using the cable they sent with the device, is there a special port I need on my PC?

The Android app shows the firmware is at 1.07.

 

Thanks!

 

UPDATE 3:45 p.m. Central

Got word from BTS support via email, and they said to try another USB-C cable.  I looked all over town, and just about gave up but when pumping gas, they had one at the checkout counter.  Worked the first time.  Of course I did the 1.08 update from BTS first (no Low Latency), then the secret one offered by sdbirder and voila.... + sign on Equinox 600 indicating APTX Low Latency Enabled!

  • Like 1

Share this post


Link to post
Share on other sites
3 hours ago, Muerte33 said:

UPDATE 3:45 p.m. Central

Got word from BTS support via email, and they said to try another USB-C cable.  I looked all over town, and just about gave up but when pumping gas, they had one at the checkout counter.  Worked the first time.  Of course I did the 1.08 update from BTS first (no Low Latency), then the secret one offered by sdbirder and voila.... + sign on Equinox 600 indicating APTX Low Latency Enabled!

I thought you would have figured that out by reading my post with the exact same experience.  Lol.  Glad you got it to work, finally.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By Steve Herschbach
      Is there anyone that for any reason still prefers the older version 1.5.0 software over the newer 1.7.5? If so, why? Just curious.
      Equinox - How To Check Version Or Rollback To Older Version
    • By Dave.H
      Some folks here may find this interesting, I certainly did!
      Testing my equinox 800 in my home test garden today, ground not high on mineralisation, but full of iron, old rusty nails etc.
      Had a silver UK sixpence 1930's buried only about 4/5 inches deep iron nails below and all around. (Difficult target)
      Imagine a clock face, I'm sweeping from 12 o'clock to 6 o'clock , good 2 way tone, no problem, now sweeping from 3 o'clock to 9 o'clock, 1 way signal, one tone only sweeping from left to right (from 3 o'clock back to 9 o'clock)
      Here's the interesting discovery reference ground balance, on my test garden there's so much iron getting a true GB is impossible, when I do try to auto GB it jumps up to the high 90's! However most of my permissions here in the UK read a GB in the mid 40's to the mid 50's so generally that's where I leave my GB most of the time.
      Ok GB set at 50, one way target from 3 o'clock to 9 o'clock, sweeping from 3 back to 9 gives me a one way tone.
      Increasing the GB to 90 gave the opposite, still a one way tone, but in reverse ,now sweeping from 9 back to 3,, still a good 2 way tone sweeping from 12 to 6!
      Lowering the GB to 75, amazing, perfect 2 way tone, 3 to 9,, and 9 to 3.
      Just thought I would share this as I found the results very interesting!
      (GB set at 0 gave no tone whatsoever from 3 o'clock to 9 o'clock)
      Program used field 2 , 50 tones, multi, discrimination -9/+1, iron bias 1, stock 11" coil, sensitivity (tried 17/21 not a great deal of difference)
      Regards Dave. H
       
       
       
       
    • By phoenix
      A couple of months ago I put out a call for the parts list for the WM12 because my original WM12 was taking forever to charge.          At the same time I bought the replacement battery, I also bought some heavier charging cables because I have about half a dozen devices that all use the same cable. I bought cables that were listed as suitable for external hard drives and they were about 6 bucks each. Because I kept changing cables on different devices I don`t even know now what cables came with the WM12.         Anyway, with the heavier charging cables my original WM12 now charges QUICKER than the newer WM12, so I don`t need to fit the battery.        Maybe, if your WM12 is getting sluggish charging, it may not be the battery, it may be the cable breaking down.   Just a thought.    Dave
       

    • By lepreshawn
      Is there any wireless headphones on the market that support aptx low latency codec and can take a rain shower or a splash of water?
      If not, someone needs to make them. 
    • By calabash digger
      Testing the program on numerous targets..
       
    • By calabash digger
      Testing out the Jones beach Land program...
       
×
×
  • Create New...