Jump to content

Finally Minelab Take Responsibility For Screwing Up The GPX 6000 Speaker


The GPX Audio Fix Poll  

13 members have voted

  1. 1. Have you had the audio/EMI fix done to your GPX 6000 - if you plan to get it done please don't answer the poll until you've got it back and tested it

  2. 2. Did the fix improve your built in speaker EMI stability

    • Yes
    • No
      0
    • Not sure, possibly
    • Not sure, I don't think so
      0
    • Don't care, not getting it done
  3. 3. Did the fix improve overall stability or improve the detector in some other way?

    • Yes
    • No
      0
    • Not sure, possibly
    • Not sure, I don't think so
      0
    • Don't care, not getting it done


Recommended Posts

Detector is back in my hot callused hands and the outside has all of the character it left my house with. So whatever the fix is, it's inside the machine away from my prying eyes. Powered on fine but had the usual "why did you turn me on inside a building" chaos. Will come back to gripe if I take it out to the field and the issue persists.

Invoice had 1.7 hrs of warranty labor on it.

  • Like 4
  • Thanks 2
Link to comment
Share on other sites


On 10/6/2022 at 10:51 AM, WesD said:

I never actually noticed the speaker to be that much more stable than the headphones.  As in the headphones dont clear up the emi warbles. I remember early on that JP posted the headphones were more stable, but on my 6k its bad either way.  Hope this is the fix...

Yes, for me also headphones was not really a fix, which is why I thought it was more a software issue.

As far as people being defensive or pretending the issue did not exist, this topic was discussed and acknowledged on these forum by anyone that knew what they were talking about, from the very start. JP pointed it out almost immediately. There were some who were not experiencing the problem, however, and some of them were less than gracious and empathetic to those that were. It helps to remember that just because we are not having a problem, does not mean that others are not. For me it was never more than a temporary annoyance, so I took it less seriously than others, who may have had more serious versions of the problem. The fact appears to be the severity varies unit to unit, for reasons I do not understand.

  • Like 2
Link to comment
Share on other sites

Tom and Jason I am curious to know if it fixed your issues.  For me, like Steve said above, it’s a temporary annoyance.  However I’m still finding gold and I don’t really want to risk sending it in to get fixed if it might reduce performance. So I am really curious what you guys find out.

  • Like 1
Link to comment
Share on other sites

5 minutes ago, afreakofnature said:

Tom and Jason I am curious to know if it fixed your issues.  For me, like Steve said above, it’s a temporary annoyance.  However I’m still finding gold and I don’t really want to risk sending it in to get fixed if it might reduce performance. So I am really curious what you guys find out.

A proper fix can only improve performance, by reducing unwanted noise.

This sets up a scenario where all 6000's sold until now will exist under a cloud of sorts, something always to be aware of if buying used. Between coil cracks and this, it is going to be a case where a GPX 6000 made in 2023 is probably going to include fixes for these problems.

  • Like 3
Link to comment
Share on other sites

5 minutes ago, Steve Herschbach said:

A proper fix can only improve performance, by reducing unwanted noise.

This sets up a scenario where all 6000's sold until now will exist under a cloud of sorts, something always to be aware of if buying used. Between coil cracks and this, it is going to be a case where a GPX 6000 made in 2023 is probably going to include fixes for these problems.

Your advice is gold as usual.  I will probably wait until Dec 31 when the USFS roads close and send it in.  😁

This is like cars now too.  I refuse to buy any car made between 2020 and 2023.  

  • Like 1
Link to comment
Share on other sites

I thought I did the right thing waiting over a year to buy my 6000, I waited and waited, suffered through not having on when everyone else did.... yet mine still had all the known faults, the initial power on error, hissing headphones, headphones that never stop charging, twisting shaft, my coil was faulty and I have the EMI noise associated with the speaker, for me factory reset works better than "headphones", headphones seem to lessen the chances of it happening a little bit but they're not the fix and it still happens using them, it's why I tried that Torus neck speaker as I wanted a speaker and not the EMI problem.  I am wondering if my detector was new old stock where it sat at my dealer for a long time, he only carried 1 in stock at a time as it wasn't a big seller here but who knows how long it sat there or at the NZ Minelab distributor,  It may have sat there since JW bought his early on right at the start when the 6000 came out for all I know and be the same early batch.   Very few of them have sold here and the gold detecting world is small enough most people know each other, even if only online.  Two of the 4 people I know of that bought one on sold it again not long after buying it, one of the two I had had the EMI issue as a contributing factor the other I don't know enough to know their genuine reason they were just not going to use it enough so sold it near straight away.

I must contact Minelab today about the speaker problem, I've not bothered so far as I'm not using the detector anyway, out of sight out of mind, at least I hoped.  I'd love a 6000 without the stability problem, the aftermarket coils have made the detector run quieter how I'd like it but they didn't solve it's bizarre EMI problem that only a factory reset seems to solve most of the time, other times the solution is use something else.  JW was talking to me the other day and his EMI problem was so bad a few days ago there was nothing he could do, factory resets and so on did nothing to fix it, he just had to press on, late in the day out of nowhere it just started running quieter and worked fine.  This is in an area we hunt often and are very aware of how EMI should be in the area and it should not cause problems like that.  I have had the same problem when we are both detecting in the same area, my 6000 was useless, totally unusable and his 6000 100 feet away worked fine all day, yes we swapped exact locations during the day.  It's such a strange issue.

If they can start making better quality coils (so far the 11" coil seems the best coil for sensitivity on the GPX) and also resolve the stability EMI but not EMI issue and try and solve the simple things like the twisting shaft then they really have a good detector, it just seemed it was released too early while they hadn't ironed out all of the problems.  I would be a big fan of the 6000 if it was the detector they intended to release.

Steve is right, having this problem fixed isn't going to lessen your performance, it has to improve your performance, if the detector is getting EMI even if self generated by a faulty component isn't going to be performing as it should, it would perform better if working how intended.

Link to comment
Share on other sites

They need to publish a range of affected unit serial #'s so the public can know. It's just basic business ethics. People have lost $1000+ selling their 6000's they could not get to work in their locations and were unable to tell if it was a bad machine, operator error, bad EMI location, or just how the machine acts normally. Letting more people take losses because they are unsure if their detector has a problem or not is unethical business IMO.  

They also need to detail exactly what this fix address - is it just the speaker, or fixing more EMI issues? Or are we going to potentially need to send our units right back for a fix #2 next year? Do they even acknowledge there are EMI/stability issues beyond just the speaker issue?

Do units currently manufactured still have issues? Are dealers still carrying/selling units that just need sent right back for repair as new? Who knows. They need to tell us. 6 months ago. 

24 minutes ago, phrunt said:

This is in an area we hunt often and are very aware of how EMI should be in the area and it should not cause problems like that.  I have had the same problem when we are both detecting in the same area, my 6000 was useless, totally unusable and his 6000 100 feet away worked fine all day, yes we swapped exact locations during the day.  It's such a strange issue.

This is the part I was trying to drive home on the forums a few months back too. After I left Arizona last winter and travelled around more I realized that there was some kind of strange issue where the location itself seemed to be affecting the 6000 with regards to stability and EMI. I found the same thing - some places just totally undetectable, while I get on my ATV on ride a short distance away and I can detect again. Go back to the first location and it was still undetectable.

Also the setting the 6000 on the ground and losing stability thing seems to affect a number of units as well.

There is the speaker issue, that's one thing. But there is something more EMI related too. Bad shielding? overwhelmed firmware/CPU resources? I have no clue since we can't even open the box up to see ourselves, but something is happening there.

So it seems to me that either there another fix #2 coming, or Minelab is not disclosing the extent of both the problem and/or the extent of what the fix addresses at this time. 

  • Like 4
Link to comment
Share on other sites

2 minutes ago, jasong said:

They need to publish a range of affected unit serial #'s so the public can know. It's just basic business ethics. People have lost $1000+ selling their 6000's they could not get to work in their locations and were unable to tell if it was a bad machine, operator error, or bad EMI location. Letting more people take losses because they are unsure if their detector has a problem or not is unethical business IMO.  


So it seems to me that either there another fix #2 coming, or Minelab is not disclosing the extent of both the problem and/or the extent of what the fix addresses at this time. 

🙂

They should put a little serial  number checker on their website where you enter your serial number and it tells you if you need to send it back or not.  I'm betting a lot of people have a dud and don't know it as they think it's normal as they were told its because its such a high sensitivity detector and Minelab even put out the primary notice saying just use headphones to calm it down and do lots of noise cancels.   They didn't even want to say an approximate date they resolved the issue, and the notice is only very recent, put two and two together and they only solved the issue a couple of months ago.    They have said they know the serial numbers with the fault, so a simple solution and will speed up the process for everyone.   It's in their best interest to not get everyone sending faulty units back, that costs them money.  What they seem to not understand is having a bunch of faulty very high priced detectors out there is doing damage to their reputation.  Profit or reputation, which means the most to them? So far it's clear its profit.  This is what happens when there are no choices in the market, no competition.... they've got us by the short and curlys, very little we can do, can't just say screw Minelab I'm buying "X" brand from now on.

  • Like 3
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...